Suspended phone number verification
Incident Report for Edgeless Casino
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 15, 2019 - 12:24 EEST
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Apr 12, 2019 - 08:28 EEST
This incident affected: Authentication.