Issues with authenticating to casino
Incident Report for Edgeless Casino
Resolved
This incident has been resolved.
Posted 13 days ago. Sep 04, 2019 - 10:59 EEST
Identified
The authentication service is down. We are working to bring it back.
Posted 13 days ago. Sep 04, 2019 - 10:51 EEST
This incident affected: Authentication.