Deposits & Withdrawals stopped or has delays
Incident Report for Edgeless Casino
Resolved
This incident has been resolved.
Posted 4 months ago. May 18, 2019 - 10:53 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. May 18, 2019 - 10:41 EEST
Investigating
We are currently investigating this issue.
Posted 4 months ago. May 18, 2019 - 10:38 EEST
This incident affected: Deposits & Withdrawals.